Ramblings of this guy you know!

Tech Stuff and random observations on life as I see it….

Tag Archives: Invalid characters

The Curious Case of Sharepoint and file uploading

Its been a frazzling sort of morning… We’ve been trying to migrate some of the Schools finance information from a shared folder space tied down with access rights… As its become more complicated to sort out who has access to what, the user rights list has gotten mixed up over time… So I had the bright idea to move it to a Sharepoint area… Me and my big ideas.

We’ve been playing with the Webdav connection and thought that it was going to be a simple process of file copying from one area to another… One of those two minute jobs that took much much longer to resolve than you thought… You know the ones.

The problems began when we compared the files in the original folder to those that were in the new folder… It was out by over 90 files but there had been no error reported back. Tried copying the files and folders again using a sync tool with a report and got a number of “Access Denied” or “<file> to large to copy” messages. It was only when we tried uploading the file manually to Sharepoint that the penny finally dropped

The file name is invalid or the file is empty. A file name cannot contain any of the following characters: \ / : * ? ” < > | # { } % ~ &

OK, so now we have the root cause of the problem, invalid characters in filenames and folders…. But how many of them do we have… Thats when we found that Windows Search is a pain in the arse… trying various incarnations of “&” or “*&*” just yields a result of all files and it was only after finding a random entry in a forum post that we got the answer that must be preserved across time; To find any of the invalid characters listed above, put the following in the search bar:

file:”&”

and you will find all the file with & in the title… Found 11 of those. But when we looked up + we found 90+ items… Passed that one back to the office to fix.

%d bloggers like this: